• RSS 0.91
  • RSS 1.0
  • RSS 2.0
  • ATOM 0.3
  • OPML

Extended Menu with JoomFish


If you are using JoomFish you may get the following message:
In the meantime the following function reference
can be commented out and translation should not be affected.


This is because the Extended Menu is backward compatible to MambleFish while JoomFish still appears to be MambleFish but then JoomFish causes the message to appear instead of being either not or fully backward compatible to MambleFish.


Workarounds would either have Extended Menu to be aware of JoomFish (which seems unnecessary since it is not supposed to call any method anymore) or remove the backward compatibility to MambleFish completely. The best solution might be to make JoomFish not pretend to be MambleFish anymore.

This was found and tested by a user and not myself:
In mambots/system/jfdatabase.systembot.php there is the following line which you can uncomment/remove:
  1. $GLOBALS[ 'mosConfig_mbf_content' ] = '1';

You may also find an old entry for mosConfig_mbf_content in your configuration.php.
Make sure it is either removed or set to '0';

Feel free to raise a bug report at JoomFish (if there is no such entry already).